Вопрос задан 22.10.2020 в 19:09.
Предмет Информатика.
Спрашивает Фролов Николай.
Составьте программу (Паскаль) для решения задачи: В игре "Русское лото" из мешка случайным
образом выбираются бочонки , на каждом из которых написано число от 1 до 50. Напишите программу, которая выводит наугад первые 3 выигрышных номера.Ответы на вопрос
Отвечает Петруненко Кристина.
Ответ:
program Loto;
var
L: array [1..50] of Integer;
a: array [1..3] of Integer;
i, j, n: Integer;
b: Boolean;
begin
for i := Low (L) to High (L) do
L [i] := i;
Randomize;
for i := 1 to 3 do begin
repeat
n := Random (51) + 1;
until L[n] <> 0;
a [i] := L [n];
L [n] := 0;
end;
for i := 1 to 3 do
Write (a [i], ' ');
ReadLn;
end
Объяснение:
сделана проверка чтобы 3 числа не совпадали друг с другом
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
