Вопрос задан 19.10.2020 в 06:35.
Предмет Информатика.
Спрашивает Силуянов Илья.
Составьте программу вычисления произведения тех значений элементов двумерного массива, которые
меньше 15. Задача ПаскальОтветы на вопрос
Отвечает Харламов Валерий.
Условие элемент массива меньше 15 и не равен нулю потому, что иначе произведение почти всегда будет равно нулю. Если оно не нужно - удали фрагмент 'and(a[i,j]<>0)'
Program n1;
Uses CRT;
Const n=10;
Var a: array[1..n,1..n] of integer;
i,j: integer; p: longint;
begin
p:=1;
For i:=1 to n do
begin
For j:=1 to n do
begin
a[i,j]:=random(50);
if (a[i,j]<15)and(a[i,j]<>0) then p:=p*a[i,j];
write(a[i,j]:3);
end;
writeln;
end;
writeln('Proizvedenie =',p);
readln
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
