Вопрос задан 18.10.2020 в 00:47.
Предмет Информатика.
Спрашивает Андреевский Андрей.
Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных
чисел, которые вводятся с клавиатуры. вид экрана: Введите числа. Для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел:3 сумма чисел:83 Среднее арифметическое:27.67 С ЦИКЛОМ While do пожалуйста напишите а не с Repeat untillОтветы на вопрос
Отвечает Макеева Татьяна.
program z8;
uses crt;
var
i,k,n:byte;
s:integer;
sa:real;
begin
clrscr; i:=1;
writeln('Для завершения последовательности нажмите ноль');
while i>0 do begin
read(i);
write(' '); {- нужен, чтобы числа нормально смотрелись}
if i>0 then begin
k:=k+1;
s:=s+i;
end; end;
sa:=s/k;
write('введено чисел:',k,' сумма чисел:',s,'Среднее арифметическое:',sa:4:2);
readkey
end.
Отвечает Горюшкин Влад.
uses crt;
var a,n,s,ar:real;
begin
a:=1;
n:=-1;
s:=0;
writeln('Введите последовательность чисел: ');
while a<>0 do begin
read(a);
n:=n+1;
s:=s+a;
end;
ar:=s/n;
writeln('Введено чисел: ',n);
writeln('Сумма чисел: ',s);
writeln('Среднее арифметическое: ',ar);
end.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
