Составьте программу, которая по введенному k – числу цветков печатает фразу «В букете k цветков»,
причем согласовывает окончание слова «цветок» с числом k. НА ПАСКАЛЕОтветы на вопрос
В Паскале вы можете использовать конструкцию `if` и `else` для согласования окончания слова "цветок" с числом `k`. Вот пример программы на Паскале:
```pascal program BouquetProgram;
var k: integer;
begin // Ввод числа цветков write('Введите количество цветков (k): '); readln(k);
// Проверка и согласование окончания if (k mod 10 = 1) and (k mod 100 <> 11) then writeln('В букете ', k, ' цветок') else if ((k mod 10 >= 2) and (k mod 10 <= 4)) and ((k mod 100 < 10) or (k mod 100 >= 20)) then writeln('В букете ', k, ' цветка') else writeln('В букете ', k, ' цветков');
end. ```
В этой программе используется оператор `if` для проверки различных условий, определяющих, какое окончание следует использовать для слова "цветок". Условия основаны на правилах русского языка: один цветок, два, три, четыре цветка, пять, шесть, семь, восемь, девять, десять цветков, и так далее.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
