(на языке C++) ! напишите программу!!! как сделать типа пишешь 123 а тебе выдаёт 3+2+1=6 пример
674= 7+6+4=17 431= 4+3+1=8 и.т.дОтветы на вопрос
Я могу помочь вам написать программу на языке C++, которая принимает число и выводит сумму его цифр в обратном порядке. Вот пример кода, который делает это:
```c++
#include
int main() { // Получаем число от пользователя int num; cout << "Введите число: "; cin >> num;
// Переменная для хранения суммы цифр int sum = 0;
// Переменная для хранения результата в обратном порядке int reverse = 0;
// Пока число не равно нулю while (num != 0) { // Получаем последнюю цифру числа int digit = num % 10;
// Добавляем ее к сумме sum += digit;
// Добавляем ее к реверсу, умножая на 10 reverse = reverse * 10 + digit;
// Убираем последнюю цифру из числа, деля на 10 num = num / 10; }
// Выводим результат cout << reverse << "=" << sum << endl;
return 0; } ```
Вы можете запустить этот код и проверить его работу. Надеюсь, это поможет вам.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
