Вопрос задан 01.09.2020 в 03:41. Предмет Информатика. Спрашивает Дивногорская Олеся.

РЕБЯТ!!! На языке pascal нужно вычислить среднее арифметическое чисел ОТ 11 ДО 20 через repeat

until. Бог в помощь ребят))
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке Pascal, которая вычислит среднее арифметическое чисел от 11 до 20 с использованием цикла `repeat...until`. Вот пример такой программы:

```pascal program CalculateAverage; var sum, count, number: integer; average: real; begin sum := 0; // Инициализируем сумму нулем count := 0; // Инициализируем количество чисел нулем // Используем цикл repeat...until для ввода чисел repeat writeln('Введите число (от 11 до 20): '); readln(number); // Проверяем, что число находится в нужном диапазоне if (number >= 11) and (number <= 20) then begin sum := sum + number; // Добавляем число к сумме count := count + 1; // Увеличиваем счетчик чисел end else writeln('Число не входит в диапазон от 11 до 20.'); until count = 10; // Повторяем цикл до тех пор, пока не введем 10 чисел // Вычисляем среднее арифметическое average := sum / count; writeln('Среднее арифметическое чисел от 11 до 20: ', average:0:2); end. ```

Эта программа сначала инициализирует переменные `sum` (сумма введенных чисел) и `count` (количество введенных чисел) нулевыми значениями. Затем она входит в цикл `repeat...until`, который позволяет пользователю вводить числа и проверяет, что введенные числа находятся в диапазоне от 11 до 20. Как только пользователь введет 10 чисел, цикл завершится, и программа вычислит среднее арифметическое введенных чисел и выведет его на экран.

Надеюсь, это поможет вам решить вашу задачу на Pascal. Если у вас есть какие-либо вопросы или требуется дополнительное пояснение, пожалуйста, дайте знать!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос