Вопрос задан 01.08.2020 в 19:13.
Предмет Информатика.
Спрашивает Железнов Егор.
Написать программу. В программу вводится n чисел, величину n задаёт пользователь, а также числа
вводятся подряд. 1.Найти сумму введённых чисел. 2.Количество чисел равных 0. 3.Найти максимум и минимум среди введённых чисел. Нужно на языке С. Помогите пожалуйста.Ответы на вопрос
Отвечает Даниил Ахмедов.
Крч вот на паскале, на Си не могу, сорь
program llllll;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
writeln('Введите количество чисел');
readln(n);
b:=0;
for i := 1 to n do
readln(A[i]);
for i := 0 to (n) do
b := b+ A[i];
write('Это сумма ');
writeln(b); // Это сумма.
b:=0;
for i := 1 to (n) do
begin
if A[i] = 0 then
b := b+1
end;
write('Это количество нулей ');
writeln(b) ;// это количество нулей
b:= -1001;
for i := 1 to (n) do
begin
if A[i] > b then
b := A[i]
end;
write('Это максимальное число ');
writeln(b); // Это максимальное число
b:= 1001;
for i := 1 to (n) do
begin
if A[i] < b then
b := A[i]
end;
write('Это минимальное число ');
writeln(b) // Это минимальное число
end.
program llllll;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
writeln('Введите количество чисел');
readln(n);
b:=0;
for i := 1 to n do
readln(A[i]);
for i := 0 to (n) do
b := b+ A[i];
write('Это сумма ');
writeln(b); // Это сумма.
b:=0;
for i := 1 to (n) do
begin
if A[i] = 0 then
b := b+1
end;
write('Это количество нулей ');
writeln(b) ;// это количество нулей
b:= -1001;
for i := 1 to (n) do
begin
if A[i] > b then
b := A[i]
end;
write('Это максимальное число ');
writeln(b); // Это максимальное число
b:= 1001;
for i := 1 to (n) do
begin
if A[i] < b then
b := A[i]
end;
write('Это минимальное число ');
writeln(b) // Это минимальное число
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
