Вопрос задан 01.08.2020 в 15:34.
Предмет Информатика.
Спрашивает Ксенофонтов Алексей.
Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом.
Pascal ABCОтветы на вопрос
Отвечает Тот-Самый Владимир.
var
s: string;
function Invert(s: string): string;
var
i: integer;
t: string;
begin
t := '';
for i := 1 to length(s) do
t := s[i] + t;
Invert := t;
end;
begin
Write('Введите слово: ');
Readln(s);
s := Trim(s);
s := Uppercase(s);
if Invert(s) = s then
Writeln('Палиндром')
else
Writeln('Не палиндром');
end.
Отвечает Шокбар Алмат.
Var
s:string;
i,n:byte;
p:boolean;
begin
Write('Введите слово: ');
Readln(s);
n:=Length(s);
p:=true;
for i:=1 to n div 2 do
if s[i]<>s[n-i+1] then
begin
p:=false;
break
end;
if p then Writeln('Палиндром')
else Writeln('Не палиндром')
end.
s:string;
i,n:byte;
p:boolean;
begin
Write('Введите слово: ');
Readln(s);
n:=Length(s);
p:=true;
for i:=1 to n div 2 do
if s[i]<>s[n-i+1] then
begin
p:=false;
break
end;
if p then Writeln('Палиндром')
else Writeln('Не палиндром')
end.
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
