
Вопрос задан 01.08.2020 в 09:24.
Предмет Информатика.
Спрашивает Степанова Александра.
СРОЧНО!!! Решить задачу на Паскале на компьютере: Найти сумму нечетных положительных чисел из N
введенных чисел. ЗАРАНЕЕ СПАСИБО!!! (через for) program z1; var i,a:real; s,n: integer; writeln('введите кол-во чисел'); readln(n);s:=0; for i:=1 to n do begin; readln(a); if a mod 2 <>0 and a>0 then begin s:=s+a end; end; writeln (s); end. Начала решать, не получается(((

Ответы на вопрос

Отвечает Хачикян Коля.
var a,s,mn:real; n,i:integer; begin clrscr; repeat write('Сколько чисел ввести n>0 n='); readln(n); until n>0; writeln('Введите ',n,' чисел:'); s:=0; for i:=1 to n do begin write('a='); readln(a); if i=1 then mn:=a else if odd(i)and(a<mn) then mn:=a; if(i mod 2=0)and(a>0) then s:=s+a; end; writeln('Сумма положительных с четными индексами=',s:0:2); writeln('Минимальный с нечетным индексом=',mn:0:2); readln end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili