Вопрос задан 24.07.2020 в 17:58.
Предмет Информатика.
Спрашивает Ефлутина Елена.
Напишите программу вычисления сторон треугольника a, b, c, если треугольник задан координатами
своих вершин (х1:y1), (x2:y2), (x3:y3). Длинна стороны вычисляется по формуле которую трудно написать и я прилогаю фотку (сорян за шакальное качество) Плюс миллион вам в карму за решение и 50 очков опыта )) только обязательно что бы программа могла считать не только A сторону...а-то воспримите буквально формулу
Ответы на вопрос
Отвечает Тысячина Анастасия.
Var x1,y1,x2,y2,x3,y3,a,b,c:real;
begin
write('x1, y1: '); readln(x1,y1);
write('x2, y2: '); readln(x2,y2);
write('x3, y3: '); readln(x3,y3);
a:=sqrt(sqr(x2-x1)+sqr(y2-y1));
b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
c:=sqrt(sqr(x3-x1)+sqr(y3-y1));
writeln('a = ',a:4:2,' b = ',b:4:2,' c = ',c:4:2);
end.
Пример:
x1, y1: 1 1
x2, y2: 4 1
x3, y3: 4 5
a = 3.00 b = 4.00 c = 5.00
begin
write('x1, y1: '); readln(x1,y1);
write('x2, y2: '); readln(x2,y2);
write('x3, y3: '); readln(x3,y3);
a:=sqrt(sqr(x2-x1)+sqr(y2-y1));
b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
c:=sqrt(sqr(x3-x1)+sqr(y3-y1));
writeln('a = ',a:4:2,' b = ',b:4:2,' c = ',c:4:2);
end.
Пример:
x1, y1: 1 1
x2, y2: 4 1
x3, y3: 4 5
a = 3.00 b = 4.00 c = 5.00
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
