Вопрос задан 11.07.2020 в 17:33. Предмет Информатика. Спрашивает Мазюк Вова.

Cоставить схему алгоритма и написать программу вычисления таблицы значений функции f(x) на

промежутке x [xн; xк] с шагом h.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рубчинский Дима.
Преобразуем формулу в рекуррентную.
\displaystyle f(x)=\sum_{k=1}^5 \frac{(-2)^{k+1}(k+1)!}{(x+2.5)^{k+1}}=\sum_{k=1}^5 \frac{(-1)^{k+1}\cdot2^{k+1}(k+1)!}{(x+2.5)^{k+1}} = \\  \\ \sum_{k=1}^5 \left[ (-1)^{k+1} \left( \frac{2}{x+2.5}\right)^{k+1}(k+1)!\right] = \sum_{k=1}^5a_k \\  \\ a_1=(-1)^2\left( \frac{2}{x+2.5}\right) ^2\cdot 2!= \left( \frac{2}{x+2.5}\right) ^2\cdot 2 \\  \\ 
a_2=(-1)^3\left( \frac{2}{x+2.5}\right) ^3\cdot 3!= -\left( \frac{2}{x+2.5}\right) ^2\cdot 3!= \\  \\ -a_1 \frac{2}{x+2.5} \cdot 3
\boxed {\displaystyle  a_k=-a_{k-1}\cdot \frac{2}{x+2.5} \cdot (k+1)}

var
  i,k:integer;
  x,s,a:real;
begin
  x:=-2;
  while x<=3 do begin
    a:=sqr(2/(x+2.5))*2;
    s:=a;
    for k:=2 to 5 do begin
      a:=-a*(2/(x+2.5))*(k+1);
      s:=s+a
      end;
    Writeln('x=',x:4:1,', f(x)=',s);
    x:=x+0.5
    end
end.

Результаты
x=-2.0, f(x)=2832032
x=-1.5, f(x)=42584
x=-1.0, f(x)=3604.93827160494
x=-0.5, f(x)=620
x= 0.0, f(x)=157.46048
x= 0.5, f(x)=51.2592592592593
x= 1.0, f(x)=19.8483285025797
x= 1.5, f(x)=8.75
x= 2.0, f(x)=4.27306135582313
x= 2.5, f(x)=2.27072
x= 3.0, f(x)=1.29731462817256
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос