Вопрос задан 07.06.2018 в 00:43.
Предмет Информатика.
Спрашивает Кузнецов Виталий.
Очень срочно Напишите программу которая находит минимальное и максимальное среди чётных
положительных чисел, записенных в файле, и выводит результат в другой файл. Учтите что таких чисел может вообще не бытьОтветы на вопрос
Отвечает Баграновская Даша.
Const
lim=2000000;
var
d,max,min:longint;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
max:=-lim; min:=lim;
while not Eof(f) do begin
Readln(f,d);
if (d>0) and (d mod 2=0) then
if max<d then max:=d
else if min>d then min:=d;
end;
Close(f);
Assign(f,'output.txt'); Rewrite(f);
if min<>lim then Writeln(f,min,' ',max);
Close(f);
end.
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 2231
Информатика 86
Информатика 50
Информатика 234
Информатика 31
Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
