Вопрос задан 26.06.2020 в 17:53. Предмет Информатика. Спрашивает Ледовской Иван.

Составьте программу которая выводит только те числа котрые делятся на 7

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Коршков Никита.
Возможно нерационально но, пусть. Сначала вы вводите количество чисел, потом сами числа. Если число делится на 7 - то будет соответствующая строка, после чего будет предложено ввести новое число; Если нет, то будет предложено ввести новое число.
program cv;
var
a,i,chislo:integer;
begin
writeln ('Введите количество чисел');
readln (a);
for i:=1 to a do
begin
writeln ('Введите число');
readln (chislo);
if (chislo mod 7=0) then writeln ('Число ',chislo,' делится на 7.')
end;
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос