Вопрос задан 06.06.2018 в 10:16.
Предмет Информатика.
Спрашивает Большакова Мария.
Помогите с паскалем, у меня практика, это очень срочно... 1. Вычислите выражение при заданных
константах: A=16.5; b=3.4; x=0.61; 2. Составить программу вычисления значения функции. На экран вывести функцию (записанную на Паскале) вместе с результатом.у={a+b+cx^2,если 1<=x<2(a*sin(xb))^2,если 2<=x<3под корнем |a+bx^2|+c ,если 3<=x<4a*ln|b+c/2x| ,если 4<=x<5e^esinx+c^3 ,если 5<=x<6Пожалуйста...

Ответы на вопрос
Отвечает Дзукаева Милана.
1)
uses crt;
const a=16.5;b=3.4;x=0.61;
var s,q:real;
begin
s:=x*x*x*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))+a/sqrt(x+b);
q:=(b*x*x-a)/(power(e,a*x)-1);
writeln('s: ',s:0:4,' q: ',q:0:4);
end.
2)
uses crt;
const a=16.5;b=3.4;
var f,c,x:real;
begin
writeln('Введите c,x:');
read(c,x);
if (x<1) or (x>=6) then
writeln('NULL')
else if (x>=1) and (x<2) then
f:=a+b*x+c*x*x
else if (x>=2) and (x<3) then
f:=(a*sin(x*b))*(a*sin(x*b))
else if (x>=3) and (x<4) then
f:=sqrt(abs(a+b*x*x)+c)
else if (x>=4) and (x<5) then
f:=a*ln(b+c/(2*x))
else if (x>=5) and (x<6) then
f:=power(e,e*sin(x))+c*c*c;
writeln(f:0:4);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
