Вопрос задан 02.06.2020 в 19:38.
Предмет Информатика.
Спрашивает Нольчан Юлия.
Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с
защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) Делать в Turbo PascalОтветы на вопрос
Отвечает Бацан Анастасія.
function sum (n : integer) : integer;
begin
sum := 0;
while n > 0 do
begin
sum := sum + n mod 10;
n := n div 10;
end;
end;
var
a : integer;
begin
repeat
writeln ('a = ');
read (a);
until sum (a) = 10;
writeln ('OK');
end.
Отвечает Нитка Настя.
var
a,a1,a2:integer;
begin
repeat
writeln (' Введите число');
readln (a);
a1:=a div 10;
a2:=a mod 10;
until (a1+a2=10);
writeln ('Верно ');
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
