Вопрос задан 18.05.2020 в 19:16. Предмет Информатика. Спрашивает Жерновая Анастасия.

Паскаль составьте программу определяющую какие из 4 заданных чисел делятся на 5

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пика Карина.
Var a,b,c,d:integer;
Begin
  Write('Введите 4числа: '); readln(a,b,c,d);
 if (a mod  5 = 0 ) then writeln(a,' делится на 5 без остатка');
 if (b mod  5 = 0 ) then writeln(b,' делится на 5 без остатка');
 if (c mod  5 = 0 ) then writeln(c,' делится на 5 без остатка');
 if (d mod  5 = 0 ) then writeln(d,' делится на 5 без остатка');
end.
0 0
Отвечает Огилько Дима.
program x;
uses crt;
var
mas: array[1..4] of integer;
i:integer;
begin
clrscr;
writeln('Введите 4 числа '')  ;
for i:=1 to 4 do
begin
readln(mas[i]);
     end;   
  for i:=1 to 4 do   
  if(mas[i] mod 5=0)
then
begin
     writeln('Числа без остатка  ', mas[i]);
endelse if (mas[i] mod 5<>0) then
 writeln('Числа с остатком  ', mas[i]) ;
     readln;   
 end.
0 0

Последние заданные вопросы в категории Информатика

Задать вопрос