Вопрос задан 16.05.2020 в 21:30.
Предмет Информатика.
Спрашивает Грекова Екатерина.
Помогите пожалуйста написать программу в Турбо Паскале с оператором цикла! Дана последовательность
Xn=sin(0,01n)*e^0,01n . Найти сумму членов последовательности Xn, начиная с X0 и до последнего Xn.Ответы на вопрос
Отвечает Краснушкина Дарья.
Вот листинг программы и скриншот:
uses Crt;
var n, i: integer;
Sum: real;
begin
ClrScr;
Write ( ' n = ');
ReadLn (n);
Sum:=0;
for i:=0 to n do
Sum:=Sum + sin(0.01*i)*exp(0.01*i);
WriteLn;
WriteLn ( ' Sum = ', Sum:3:3);
ReadLn;
end.
uses Crt;
var n, i: integer;
Sum: real;
begin
ClrScr;
Write ( ' n = ');
ReadLn (n);
Sum:=0;
for i:=0 to n do
Sum:=Sum + sin(0.01*i)*exp(0.01*i);
WriteLn;
WriteLn ( ' Sum = ', Sum:3:3);
ReadLn;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
