Вопрос задан 04.06.2018 в 02:23.
Предмет Информатика.
Спрашивает Смирнов Кирилл.
Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и
вывести на экран сообщение.И определить заканчивается эта сумма на 3,является ли эта сумма четнымОтветы на вопрос
Отвечает Артюшкин Никита.
//PascalABC.Net 3.2
begin
var x:=readinteger ('Введите x: ');
var sum:=0;
repeat
sum+=x mod 10;
x:=x div 10;
until x=0;
writeln ('Сумма цифр: ', sum);
writeln ('Сумма заканчивается на 3: ', (sum mod 10)=3);
writeln ('Сумма четная - ', sum.Iseven);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
