Вопрос задан 16.05.2020 в 12:43.
Предмет Информатика.
Спрашивает Чернобай Валерия.
Нужно написать программу на Pascal.Программа должна посчитать среднюю оценку ученика.Например:
"Введите ваши оценки: 54454",программа должна вывести: "Ваш средний балл: 4,4".Человек может вводить сколько угодно значенийОтветы на вопрос
Отвечает Афанасьев Никита.
Var marks:string; i,m,c,s,k:integer;
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
if marks[i] in ['2'..'5']
then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний балл: ',s/k);
end.
Пример:
Введите ваши оценки: 54454
Ваш средний балл: 4.4
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
if marks[i] in ['2'..'5']
then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний балл: ',s/k);
end.
Пример:
Введите ваши оценки: 54454
Ваш средний балл: 4.4
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
