Вопрос задан 03.06.2018 в 18:17. Предмет Информатика. Спрашивает Шевелёва Алёна.

Дан массив, содержащий 2016 целых чисел. Необходимо найти и вывести сумму тех элементов этого

массива, чётность которых совпадает с чётностью максимального элемента. Например, в массиве из 6 элементов, равных соответственно 2, 3, 1, 5, 6, 4, максимальный элемент чётный (6), значит, ответом будет сумма чётных элементов этого массива 2 + 6 + 4 = 12. Помогите написать программу на паскале
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Попов Никита.

Var a,max,sum:integer;
    arr:array [0..2015] of integer;
    begin
randomize;
max:=-500;
sum:=0;
for a:=0 to 2015 do begin
arr[a]:=random(1001)-500;
if max<arr[a] then max:=arr[a];
end;
write('максимальный элемент массива ==> ',max);
writeln();

if max mod 2 = 1 then begin
for a:=0 to 2015 do begin
if arr[a] mod 2 =1 then sum:=sum+arr[a];
end;
writeln('сумма чисел одинаковой чётности числу ',max,' = ',sum);
end;

sum:=0;
if max mod 2 = 0 then begin
for a:=0 to 2015 do begin
if arr[a] mod 2 =0 then sum:=sum+arr[a];
end;
writeln('сумма чисел одинаковой чётности числу ',max,' = ',sum);
end;

end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос