Вопрос задан 06.05.2020 в 13:58.
Предмет Информатика.
Спрашивает Агаркова Виктория.
Написать программу вычисления факториалов всех чисел до N
Ответы на вопрос
Отвечает Курская Елена.
#include<iostream>
int fact(int x){ if(!x)return 1; return x*fact(x-1);}
using namespace std;int main(){int i=0;int n;std::cin>>n;do{ ++i; std::cout<<fact(i)<<"\n";}while(i<n);
return 0;}
int fact(int x){ if(!x)return 1; return x*fact(x-1);}
using namespace std;int main(){int i=0;int n;std::cin>>n;do{ ++i; std::cout<<fact(i)<<"\n";}while(i<n);
return 0;}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
