Вопрос задан 03.05.2020 в 00:37. Предмет Информатика. Спрашивает Тареев Леша.

10 класс Составьте программу, позволяющую ввести фамилию, имя и отчество учащегося, разделенные

пробелом, и вывести фамилию и инициалы. Пример ввода: Иванов Сергей Михайлович { строка s } Пример вывода: Иванов С. М. Паскаль
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кусова Лиза.

var

str: string;

i,k: integer;

begin

write('Введите фамилию, имя и отчество: ');

readln(str);

for i:=1 to length(str) do

begin

if (str[i]<>' ')and(k=0) then

write(str[i]) else

if str[i]=' ' then

begin

inc(k);

write(' ',str[i+1],'.');

end;

end;

readln;

end.


попробуй эту программу.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос