Вопрос задан 02.05.2020 в 03:57. Предмет Информатика. Спрашивает Карасюк Сергей.

Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через

каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Опре-делить : а) за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; б) через сколько месяцев размер вклада превысит 1200 руб.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Громова Ксюша.
Var s,ds:real; k1,k2:integer;
begin
//a
s:=1000; ds:=0; k1:=0;
while ds<=30 do
 begin
 ds:=s*0.02;
 s:=s+ds;
 k1:=k1+1;
 end;
writeln('k1 = ',k1);
//б
s:=1000; ds:=0; k2:=0;
while s<=1200 do
 begin
 s:=1.02*s;
 k2:=k2+1;
 end;
writeln('k2 = ',k2);
end.

Результат:
k1 = 22
k2 = 10
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос