Вопрос задан 01.05.2020 в 15:14. Предмет Информатика. Спрашивает Сиянская Анастасия.

РЕШАТЬ ЗАДАНИЕ НА PYTHONПроверьте, является ли двумерный массив симметричным относительно главной

диагонали. Главная диагональ — та, которая идёт из левого верхнего угла двумерного массива в правый нижний. Входные данные Программа получает на вход число n <=  100, являющееся числом строк и столбцов в массиве. Далее во входном потоке идет n строк по n чисел, являющихся элементами массива. Выходные данные Программа должна выводить слово yes для симметричного массива и слово no для несимметричного. Примеры Входные данные: 3 0 1 2 1 5 3 2 3 4 Выходные данные: YES Входные данные: 3 0 0 0 0 0 0 1 0 0 Выходные данные: NO
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Неред Дима.
N = int(input('n = '))
# a = [[0, 1, 2], [1, 5, 3], [2, 3, 4]]
a = []
for i in range(n):
  row = input().split()
  for j in range(n): row[j] = int(row[j])
  a.append(row)
m = 0
for i in range(1, n):
  k = 0
  for j in range(i):
    if (a[i][j] == a[j][i]): k = k+1;
  if k == i: m = m+1
if (m == n-1): print('YES')
else: print('NO')

Пример:
n = 3
0 1 2
1 5 3
2 3 4
YES
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос