Вопрос задан 26.04.2020 в 13:51.
Предмет Информатика.
Спрашивает Дейлид Мария.
Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадратов первых n
натуральных чисел в) всех четных чисел в диапазоне от 1 до n г) всех двухзначных чисел Даю 20 баллов!!!Ответы на вопрос
Отвечает Суханова Вика.
Var
i, s1, s2, s3, s4, n: integer;
begin
write('n = ');
readln(n);
s1 := 0;
s2 := 0;
s3 := 0;
s4 := 0;
for i := 1 to n do
begin
s1 := s1 + i;
s2 := s2 + sqr(i);
if i mod 2 = 0 then s3 := s3 + i;
end;
for i := 10 to 99 do s4 := s4 + i;
writeln('Сумма первых n натуральных чисел: ', s1);
writeln('Сумма квадратов первых n натуральных чисел: ', s2);
writeln('Сумма всех четных чисел: ', s3);
writeln('Сумма всех двухзначных чисел: ', s4);
end.
i, s1, s2, s3, s4, n: integer;
begin
write('n = ');
readln(n);
s1 := 0;
s2 := 0;
s3 := 0;
s4 := 0;
for i := 1 to n do
begin
s1 := s1 + i;
s2 := s2 + sqr(i);
if i mod 2 = 0 then s3 := s3 + i;
end;
for i := 10 to 99 do s4 := s4 + i;
writeln('Сумма первых n натуральных чисел: ', s1);
writeln('Сумма квадратов первых n натуральных чисел: ', s2);
writeln('Сумма всех четных чисел: ', s3);
writeln('Сумма всех двухзначных чисел: ', s4);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
