Вопрос задан 26.04.2020 в 00:06.
Предмет Информатика.
Спрашивает Голубин Степан.
Напишите программу , которая переводит десятичные числа в эквиваленты из соответствующих систем
счисления по основанию b, 10 > b <= 36.Ответы на вопрос
Отвечает Афонин Денис.
Var i,k,j,n,ost,p:integer;
x,s:string;
begin
read(s);
n:=strtoint(s);
for j:=11 to 36 do
begin
x:='';
p:=n;
k:=0;
while p<>0 do
begin
ost:=p - (p div j)*j;
p:=p div j;
k:=k+1;
if (ost >9) and (ost <=36) then
x:=chr(ost+55)+x
else
x:=inttostr(ost)+x;
end;;
writeln(x,' ',j,' ss');
end;
end.
x,s:string;
begin
read(s);
n:=strtoint(s);
for j:=11 to 36 do
begin
x:='';
p:=n;
k:=0;
while p<>0 do
begin
ost:=p - (p div j)*j;
p:=p div j;
k:=k+1;
if (ost >9) and (ost <=36) then
x:=chr(ost+55)+x
else
x:=inttostr(ost)+x;
end;;
writeln(x,' ',j,' ss');
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
