Вопрос задан 25.04.2020 в 10:48.
Предмет Информатика.
Спрашивает Потапов Марк.
Помогите написать программу на Паскале Дана квадратная матрица размером . Найти сумму главной
диагонали и умножить на полученное число все элементы матрицы, кроме лежащих на главной диагоналиОтветы на вопрос
Отвечает Уйгурова Кюннэй.
program raf105;
const
n = 4;
var
a: array[1..n,1..n] of integer;
i,j,sum: integer;
begin
for i:=1 to n do
begin
writeln;
for j:=1 to n do
begin
a[i,j]:= random(1,9);
if i = j then
sum:= sum + a[i,j];
write(a[i,j]:4,' ');
end;
end;
writeln;
writeln;
writeln('Вывод:');
for i:=1 to n do
begin
writeln;
for j:=1 to n do
begin
if i <> j then
a[i,j]:= a[i,j] * sum;
write(a[i,j]:4,' ');
end;
end;
end.
PascalABC 3.4.2
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
