Вопрос задан 25.04.2020 в 02:47.
Предмет Информатика.
Спрашивает Митасов Васёк.
Хепланите плиз Написать программу на языке Pascal Вариант 4

Ответы на вопрос
Отвечает Высоцкий Влад.
Var pi,inR: real;
function a(RR:real; n:integer):real;
begin
a := 2*RR*sin(pi/n)
end;
function r(RR:real; n:integer):real;
begin
r := RR * cos(pi/n)
end;
function S(RR:real; n:integer):real;
begin
S := a(RR,n) * n * r(RR,n) / 2
end;
begin
pi := 4 * arctan(1);
read(inR);
writeln(S(inR,10));
writeln(S(inR,50));
writeln(S(inR,100))
end.
function a(RR:real; n:integer):real;
begin
a := 2*RR*sin(pi/n)
end;
function r(RR:real; n:integer):real;
begin
r := RR * cos(pi/n)
end;
function S(RR:real; n:integer):real;
begin
S := a(RR,n) * n * r(RR,n) / 2
end;
begin
pi := 4 * arctan(1);
read(inR);
writeln(S(inR,10));
writeln(S(inR,50));
writeln(S(inR,100))
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
