Вопрос задан 23.04.2020 в 18:35.
Предмет Информатика.
Спрашивает Великанова Рената.
Нужна помощь с программированием в Pascal. Напишите программу на задачу: "Дано действительные числа
a,b,c . Если a>b>c , то числа оставить без изменений, в противоположном случае все числа заменить на их квадраты"Ответы на вопрос
Отвечает Зубрилкина Ирина.
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!
1. Современное решение
begin
var (a,b,c):=ReadReal3;
if (a>b) and (b>c) then else (a,b,c):=(a*a,b*b,c*c);
Println(a,b,c)
end.
Пример
15.8 4.9 13
249.64 24.01 169
2. А так, увы, все еще учат писать во многих школах...
program Toska;
var
a,b,c:real;
begin
Read(a,b,c);
if not ((a>b) and (b>c)) then begin
a:=a*a; b:=b*b; c:=c*c
end;
Writeln(a,' ',b,' ',c)
end.
Внимание! Если программа не работает, обновите версию!
1. Современное решение
begin
var (a,b,c):=ReadReal3;
if (a>b) and (b>c) then else (a,b,c):=(a*a,b*b,c*c);
Println(a,b,c)
end.
Пример
15.8 4.9 13
249.64 24.01 169
2. А так, увы, все еще учат писать во многих школах...
program Toska;
var
a,b,c:real;
begin
Read(a,b,c);
if not ((a>b) and (b>c)) then begin
a:=a*a; b:=b*b; c:=c*c
end;
Writeln(a,' ',b,' ',c)
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
