Вопрос задан 16.04.2020 в 15:27. Предмет Информатика. Спрашивает Печкурова Алина.

СОСТАВИТЬ В ПАСКАЛЕ .Составьте программу вычисления суммы нечетных составных делителей кратных 5

натурального числа M. 70баллов СРОЧНО
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Попков Артём.

Код программы на языке PascalABC  

program raf105;

var m,sum,i: integer;

begin

write('M = ');

readln(m);

write('Нечётные составные делители кратные пяти: ');

for i:=1 to m do

 if (i mod 5 = 0) and (i <> 5) and (m mod i = 0) and (i mod 2 <> 0)

   then begin sum:= sum+i; write(i,' '); end;

writeln;

writeln('Их сумма: ',sum);

end.

Результат работы программы              

M = 10000

Нечётные составные делители кратные пяти: 25 125 625

Их сумма: 775

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос