Вопрос задан 15.04.2020 в 11:51.
Предмет Информатика.
Спрашивает Кириллова Полина.
Составить программу для данного условия: Вычисление суммы только положительных чисел из
последовательно введенных чисел ( остановить обработку при 100.0) . В ПаскалеОтветы на вопрос
Отвечает Токаренко Кристина.
Var a,s:real;
begin
s:=0;
repeat
readln(a);
if a>0 then s:=s+a;
until s>=100;
writeln('s = ',s:5:1);
end.
Пример:
45
-84
12
30
-30
53
s = 140.0
begin
s:=0;
repeat
readln(a);
if a>0 then s:=s+a;
until s>=100;
writeln('s = ',s:5:1);
end.
Пример:
45
-84
12
30
-30
53
s = 140.0
Отвечает Різник Лєна.
Вычисление суммы только положительных чисел из последовательно введенных чисел ( остановить обработку при 100.0)
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
