Вопрос задан 15.04.2020 в 08:27.
Предмет Информатика.
Спрашивает Самаркина Алиса.
Нужно написать программу на PascalABC. Вводится n чисел, найти максимальное двузначное среди них.
Ответы на вопрос
Отвечает Ковригина Ксения.
Var
n,max,i,a : longint;
begin
readln(n); {количество чисел}
max:=0; {чтобы вывести 0 если нет двухзначных}
for i:=1 to n do
begin
readln(a); {хранить массив не надо т.к. он нигде не требуется}
if (a>9) and (a<100) and (a>max)
then max:=a;
end;
if max>0
then writeln(max)
else writeln('нет двухзначных чисел')
end.
n,max,i,a : longint;
begin
readln(n); {количество чисел}
max:=0; {чтобы вывести 0 если нет двухзначных}
for i:=1 to n do
begin
readln(a); {хранить массив не надо т.к. он нигде не требуется}
if (a>9) and (a<100) and (a>max)
then max:=a;
end;
if max>0
then writeln(max)
else writeln('нет двухзначных чисел')
end.
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
