 
Вопрос задан 14.04.2020 в 23:08.
Предмет Информатика.
Спрашивает Изосимова Маша.
Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки
больше 1000р 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Квасов Даниил.
                
     Var
a: real;
  
begin
while a <= 1000 do
begin
writeln('Введите сумму покупки > 1000р');
readln(a);
if a > 1000 then break
else writeln('Ошибка! Введенная сумма покупки <= 1000p');
end;
writeln('Стоимость покупки с учетом скидки 10%: ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
a: real;
  
begin
writeln('Введите сумму покупки > 1000р');
readln(a);
writeln('Стоимость покупки с учетом скидки 10%: ', a * 0.9);
end.
 
                                        a: real;
begin
while a <= 1000 do
begin
writeln('Введите сумму покупки > 1000р');
readln(a);
if a > 1000 then break
else writeln('Ошибка! Введенная сумма покупки <= 1000p');
end;
writeln('Стоимость покупки с учетом скидки 10%: ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
a: real;
begin
writeln('Введите сумму покупки > 1000р');
readln(a);
writeln('Стоимость покупки с учетом скидки 10%: ', a * 0.9);
end.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			