Вопрос задан 08.04.2020 в 03:44.
Предмет Информатика.
Спрашивает Рылова Аня.
С++ Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.
Ответы на вопрос
Отвечает Илюшкин Михаил.
function Power(x,y:real):real;
{ (C) Puporev }
begin if x=0 then Power:=0
else
if x>0 then
Power:=exp(ln(x)*y)
else
Power:=-exp(ln(abs(x))*y);
end;
var x,y:real;
begin
readln(x,y);
writeln(power(x,y));
end.
{ (C) Puporev }
begin if x=0 then Power:=0
else
if x>0 then
Power:=exp(ln(x)*y)
else
Power:=-exp(ln(abs(x))*y);
end;
var x,y:real;
begin
readln(x,y);
writeln(power(x,y));
end.
Отвечает Лаас Диана.
#include <iostream>
int main()
{
float x, y;
float res = 1;
std::cin >> x >> y;
for (int i = 0; i < y; i++)
res *= x;
std::cout << res << std::endl;
}
int main()
{
float x, y;
float res = 1;
std::cin >> x >> y;
for (int i = 0; i < y; i++)
res *= x;
std::cout << res << std::endl;
}
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 21
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
