Вопрос задан 31.05.2018 в 14:22.
Предмет Информатика.
Спрашивает Зотов Николай.
Необходимо написать программу используя оператор выбора CASE. Формулировка: Составить программу,
которая по введенной с клавиатуры буквы (P,K,T) будем высчитывать площади прямоугольника, квадрата и треугольника соответственно. Попробовал решить самостоятельно: program HW; uses crt; VAR x,y:integer; { длинна и ширина прямоугольника } a,b:integer; { основание и высота треугольника } d:integer; { длина стороны квадрата } rez:real; { результат } ploshad:real; { площадь } P:real; { прямоугольник } K:real; { квадрат } T:real; { треугольник } BEGIN Write ('Если вы желаете вычеслить площадь прямоугольника, введите его длину и ширину, если же нет, оставьте это поле пустым:'); Readln (x,y); Write ('Если вы желаете вычеслить площадь квадрата, введите длину его стороны, если же нет, оставьте это поле пустым:'); Readln (d); Write ('Если вы желаете вычеслить площадь треугольника, введите его основание, а затем высоту, если же нет, оставьте это поле пустым:'); Readln (a,b); Write ('Укажите букву площади которую хотите вычеслить: прямоугольника(P),квадрата(K) или же треугольника(T) - '); Readln (ploshad); CASE ploshad OF P:rez:=x*y; K:rez:=d*d; T:rez:=0.5*a*b; Else write ('Извините, вы ввели не верный символ.'); end; begin Writeln ('Результат = ',rez:100:3); end; end. _____________________________________________ Но, при запуске программы в строке "CASE ploshad OF" выдает ошибку, что "Ожидался порядковый или строковый тип". Как исправить?Ответы на вопрос
Отвечает Ишманова Камила.
Исправил решение. Теперь все работает как нужно. код программы в файле.

Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 24
Информатика 37
Информатика 17
Информатика 34
Информатика 14
Информатика 52
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
