Вопрос задан 05.04.2020 в 09:56.
Предмет Информатика.
Спрашивает Кузнецова Алёна.
Дан массив целых чисел А(25). Составить программу для вычисления суммы элементов массива, которые
не меньше 10.Ответы на вопрос
Отвечает Григорьева Дарья.
PascalABC.NET 3.4.2, сборка 1861 от 09.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var a := ArrRandom(25, -15, 50);
a.Println;
a.Where(t -> t >= 10).Sum.Println
end.
Пример
-13 27 20 48 17 33 -6 36 12 48 -13 1 45 12 31 7 45 35 42 3 26 -10 48 27 34
586
Отвечает Шаймуратова Галия.
var a:array[1..25] of integer;
i,z:integer;
begin
for i:=1 to 25 do
begin
a[i]:=random(50);
write(a[i],' ');
if (a[i]>=10) then z:=z+a[i];
end;
writeln;
write(z);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
