Вопрос задан 01.04.2020 в 20:01.
Предмет Информатика.
Спрашивает Галкина Аня.
1.Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность
введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом).Вычисление частного.Введите в одной строке делимое и делитель,затем нажмите <enter>.-> 12 ОВы ошиблись. Делитель не должен быть равен нулю.Ответы на вопрос
Отвечает Макшаков Антон.
Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
