
Вопрос задан 27.03.2020 в 17:44.
Предмет Информатика.
Спрашивает Присенко Аня.
Напишите программу, которая размещает случайным образом две ладьи на шахматной доске и определяет,
бьют ли эти ладьи друг друга.

Ответы на вопрос

Отвечает Пельнова Дарья.
Язык СИ:
#include<stdio.h>
#include<stdlib.h>
#include<float.h>
#include<time.h>
int main(){
srand(time(0));
const long double cbc=64.0L-FLT_EPSILON;
unsigned short int r1=cbc/RAND_MAX*rand(),
r2=cbc/RAND_MAX*rand();
printf("R1: %c%c\n",65+r1%8,49+r1/8);
printf("R2: %c%c\n",65+r2%8,49+r2/8);
printf("%s\n",r1%8==r2%8 || r1/8==r2/8?"yes":"no");
return 0;
}


Топ вопросов за вчера в категории Информатика

Информатика 563

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili