Вопрос задан 17.03.2020 в 12:14.
Предмет Информатика.
Спрашивает Скоробогатый Деня.
Составьте программу для определения,что больше площадь круга радиусом a или площадь квадрата со
стороной a-значения числа a вводятся с клавиатуры(площадь круга вычисляется по формуле:S=ПиR^2)помогите пожалуйста:( паскальОтветы на вопрос
Отвечает Давыдов Егор.
Так?
var a, R: integer; S:real;
begin
writeln('Введите радиус круга');
readln(R);
writeln('Введите сторону квадрата');
read(a);
S:=3.14*R*R;
a:=a*a;
If S>a then write('Площадь круга больше площади квадрата')
else write('Площадь квадрата больше площади круга');
end.
Отвечает Кузьменко Аня.
Показываю:
1) Вводишь переменную а
2) Добавляешь переменную для площади квадрата
3) Добавляешь переменную для площади круга
4) Выполняешь вычисление по формуле и присваиваешь его переменной для площади круга, т.е. Sk=pi*r*r; (pi сразу задаешь значение - это пи)
5) Выполняешь вычисление по формуле и присваиваешь его переменной для площади квадрата, т.е. S=r*r;
6) Проверка:
если (Sk > Sv) {
вывести результат
} если нет {
вывести 2 результат
}
Удачи!
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
