Вопрос задан 06.02.2020 в 13:09.
Предмет Информатика.
Спрашивает Лебедева Полина.
Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры
положительных целых чисел а и b хотя бы одно четное. Была написана следующая программа: var a, b: integer; begin readln(a, b); a := a mod 2; if a > 0 then b := b mod 2; if b > 0 then writeln ('четных чисел нет') else writeln ('четное число есть'); end. Известно, что программа написана с ошибками. Последовательно выполните три задания: укажите, как, по вашему мнению, нужно доработать программу (не используя слож-ные условия), чтобы не было случаев ее неправильной работы;Ответы на вопрос
Отвечает Стаховский Сергей.
Var
a,b:integer;
Begin
readln(a,b);
if a mod 2= 0 then writeln('есть чётное')
else if b mod 2=0 then writeln('есть чётное')
else writeln('Нет чётных);
End.
a,b:integer;
Begin
readln(a,b);
if a mod 2= 0 then writeln('есть чётное')
else if b mod 2=0 then writeln('есть чётное')
else writeln('Нет чётных);
End.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
