Вопрос задан 02.02.2020 в 23:11.
Предмет Информатика.
Спрашивает Горошко Василь.
Помогите написать программу к задаче: В программе генерируется два случайных числа a и b в
диапазоне от 10 до 40. Определить какое число больше?Ответы на вопрос
Отвечает Коростылёв Иван.
Если паскаль, лови...
Во первых для генерации рандомного числа используется метод random(x), но он генерирует число от 1 до x, и чтоб он генерировал от какого то определенного, надо из x вычесть от какого числа генерировать, а потом к сгенерированному прибавить его random(x - n) + n. Где x - До какого числа, а n - от какого.
Для нахождения максимального числа мы будем использовать метод max, который принимает два аргумента (какие числа надо сравнить), допустим max(5,10) вернет 10, max(-1, -5) вернет -1. Так же есть min - нахождение минимального.
...
А теперь сам код:
begin
var a := random(30) + 10;
var b := random(30) + 10;
writeln('a:' + a);
writeln('b:' + b);
writeln(max(a,b));
end.
...
Если не сложно нажми "Спасибо" ;)
Во первых для генерации рандомного числа используется метод random(x), но он генерирует число от 1 до x, и чтоб он генерировал от какого то определенного, надо из x вычесть от какого числа генерировать, а потом к сгенерированному прибавить его random(x - n) + n. Где x - До какого числа, а n - от какого.
Для нахождения максимального числа мы будем использовать метод max, который принимает два аргумента (какие числа надо сравнить), допустим max(5,10) вернет 10, max(-1, -5) вернет -1. Так же есть min - нахождение минимального.
...
А теперь сам код:
begin
var a := random(30) + 10;
var b := random(30) + 10;
writeln('a:' + a);
writeln('b:' + b);
writeln(max(a,b));
end.
...
Если не сложно нажми "Спасибо" ;)
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
