Вопрос задан 24.01.2020 в 17:42.
Предмет Информатика.
Спрашивает Пафиков Виктор.
Напишите программу, которая случайным образом выбирает дежурных: выводит два случайных числа на
отрезке [1; N], где N – количество учеников вашего класса. Какая проблема может при этом возникнуть? c++Ответы на вопрос
Отвечает Скрипченко Алёна.
===== С++ 17 =====
#include <iostream>
using namespace std;
int main()
{
int n;
cout << "Количество учеников: ";
cin >> n;
srand(time(NULL));
int m1 = rand() % n + 1, m2 = rand() % n + 1;
while(m2 == m1)
m2 = rand() % n + 1;
cout << m1 << " " << m2;
return 0;
}
Топ вопросов за вчера в категории Информатика
Информатика 68
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
