Вопрос задан 24.01.2020 в 02:15. Предмет Информатика. Спрашивает Тимощук Вова.

Помогите составить программу в паскале!!Пожалуйста!В квитанции есть пятизначное число. Отчётливо

видны только две первые цифры - это 1 и 5; остальные три цифры стёрты. В среде программирования разработайте программу, которая найдёт это число, если известно, что оно кратно 57 и 67. (Подсказка: воспользуйтесь методом полного перебора.)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Новикова Лена.
// методом перебора
// Ответ: 15276

const   m=57;
        n=67;
var     i,x:word;
        q:boolean;

begin
  i:=99;
  q:=true;
  while (i<1000) and q do begin
    i:=i+1;
    x:=15000+i;
    if (x mod m=0) and (x mod n=0) then
      q:=false;
  end;

  writeln(x);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос