Составить программу на паскале для вычисления произведения A и B , чтобы она не могла пользоваться
командой умножения , a и b натуральные числаОтветы на вопрос
var
a, b, sum, index: word;
begin
sum := 0;
read(a,b);
for index := 1 to b do sum += a;
write(sum);
end.
Программа на языке Паскаль, которая вычисляет произведение двух натуральных чисел a и b без использования оператора умножения может выглядеть следующим образом:
``` program multiplication;
var a, b, result, i: integer;
begin writeln('Введите первое число a: '); readln(a);
writeln('Введите второе число b: '); readln(b);
result := 0; for i := 1 to b do begin result := result + a; end; writeln('Результат произведения a и b: ', result); end. ```
В этой программе используется цикл for, который выполняется b раз, при каждой итерации к переменной result прибавляется значение a. После завершения цикла, результат выводится на экран с помощью writeln.
Программа сначала запрашивает значение a, затем b. Затем она выполняет цикл, и в каждой итерации прибавляет значение a к результату. И, наконец, выводит результат на экран.
Например, если ввести a = 5 и b = 3, программа выведет:
``` Результат произведения a и b: 15 ```
Таким образом, программа вычисляет произведение двух натуральных чисел a и b без использования оператора умножения.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
