Написать программу, которая делает замену цифр 6-тизначного числа по схеме (abcdef в fedcba) и
выводит новое число на экран (Паскаль)Ответы на вопрос
        var n: longint;
begin
clrscr;
repeat
write('введите число') ;
readln(n);
until(n>0) and (n <=999999);
writeln(summ(n);end.
            Я могу помочь вам написать программу на языке Паскаль, которая делает замену цифр шестизначного числа по схеме (abcdef в fedcba) и выводит новое число на экран. Вот один из возможных вариантов решения этой задачи:
```pascal program ReverseDigits; var n, r: integer; begin writeln('Введите шестизначное число:'); readln(n); if (n >= 100000) and (n <= 999999) then begin r := 0; // переменная для хранения результата while n > 0 do begin r := r * 10 + n mod 10; // добавляем последнюю цифру n к r n := n div 10; // отбрасываем последнюю цифру n end; writeln('Число с обратным порядком цифр:', r); end else writeln('Неверный ввод. Число должно быть шестизначным.'); end. ```
Эта программа считывает шестизначное число n от пользователя и проверяет, что оно действительно шестизначное. Затем она использует цикл while и операции деления и остатка от деления, чтобы получить цифры n в обратном порядке и сохранить их в переменной r. Наконец, она выводит r на экран. Если введенное число не шестизначное, программа выдает сообщение об ошибке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			