Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: -
сумма цифр числа А делится на 4; - сумма цифр числа А+2 также делится на 4Ответы на вопрос
begin
for i1:=100 to 997 do
begin
s1:=(i1 div 100)+(i1 div 10 mod 10)+(i1 mod 10);
i2:=i1+2;
s2:=(i2 div 100)+(i2 div 10 mod 10)+(i2 mod 10);
if (s1 mod 4=0)and(s2 mod 4=0) then writeln(i1,' ',i2);
end;
end.
Результат:
299 301
398 400
699 701
798 800
Программа на языке Pascal для поиска всех трехзначных чисел, обладающих заданными свойствами:
``` program FindNumbers;
var number: integer;
begin for number := 100 to 999 do begin if (number div 100 + (number div 10) mod 10 + number mod 10) mod 4 = 0 then begin if ((number + 2) div 100 + ((number + 2) div 10) mod 10 + (number + 2) mod 10) mod 4 = 0 then begin writeln(number); end; end; end; end. ```
Объявляем переменную `number` типа integer для хранения трехзначных чисел. Затем запускаем цикл `for`, в котором перебираем все трехзначные числа от 100 до 999.
Внутри цикла мы проверяем два условия. Первое условие `(number div 100 + (number div 10) mod 10 + number mod 10) mod 4 = 0` проверяет, делится ли сумма цифр числа `number` на 4 без остатка. Второе условие `((number + 2) div 100 + ((number + 2) div 10) mod 10 + (number + 2) mod 10) mod 4 = 0` проверяет, делится ли сумма цифр числа `number + 2` (число, увеличенное на 2) на 4 без остатка.
Если оба условия выполняются, то выводим число `number` с помощью процедуры `writeln`.
Таким образом, программа выводит на экран все трехзначные числа, у которых сумма цифр и сумма цифр числа, увеличенного на 2, делятся на 4 без остатка.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
