Написать программу на языке Pascal Найти среднее значение цифр 2-хзначного числа x=12, S=3, Sr=15
Ответы на вопрос
Program;
var
S, Sr, x, Z: real;
begin
S := 3;
Sr := 15;
x := 12;
Z := x+S+Sr/3;
writeln(Z);
end.
Может так?
Для нахождения среднего значения цифр двузначного числа, нам необходимо первоначально разбить число на отдельные цифры, затем сложить эти цифры и поделить результат на количество цифр в числе.
Программа на языке Pascal для решения этой задачи может выглядеть следующим образом:
``` program AverageDigits;
var x, s, sr, digit1, digit2: integer; sum, average: real;
begin // Ввод данных x := 12; s := 3; sr := 15; // Получение отдельных цифр числа digit1 := x div 10; // первая цифра digit2 := x mod 10; // вторая цифра // Суммирование цифр sum := digit1 + digit2; // Вычисление среднего значения average := sum / 2; // Вывод результата writeln('Среднее значение цифр двузначного числа ', x, ' равно: ', average); readln; end. ```
В данной программе мы задаем значения переменных `x`, `s` и `sr` соответственно (`x := 12`, `s := 3`, `sr := 15`). Затем мы разделяем число `x` на отдельные цифры, используя операторы деления нацело (`div`) и остатка от деления (`mod`) на `10`. Полученные цифры сохраняем в переменные `digit1` и `digit2`. Затем мы суммируем цифры и сохраняем результат в переменную `sum`. Далее вычисляем среднее значение путем деления суммы на количество цифр, в данном случае на число `2`. Результат выводим на экран с помощью функции `writeln`.
В данной программе среднее значение цифр двузначного числа `12` будет равно `3.5`, что является искомым результатом.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
