Вопрос задан 18.01.2020 в 13:55.
Предмет Информатика.
Спрашивает Клепикова Аня.
Написать программу на языке Паскаль. Условие: если значение переменной х<0, то вычислить
квадрат переменной х, иначе значение х уменьшить в 2 раза.Ответы на вопрос
Отвечает Аскарова Акмарал.
/////////////////Pascal abc/////////////////
Программа во вложении
Программа во вложении
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам написать программу на языке Паскаль. Вот один из возможных вариантов решения вашей задачи:
```pascal program Solution; var x: real; begin readln(x); // вводим значение переменной x if x < 0 then // если x меньше нуля x := x * x // то вычисляем квадрат x else // иначе x := x / 2; // то уменьшаем x в два раза writeln(x); // выводим результат end. ```
Эта программа считывает значение переменной x с клавиатуры, затем проверяет, является ли оно отрицательным. Если да, то программа вычисляет квадрат x и выводит его на экран. Если нет, то программа делит x на два и выводит полученное значение на экран. Это соответствует условию задачи. Надеюсь, это вам поможет.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
