Напишите пожалуйста программу в Паскале:Написать программу,которая по номеру месяца выводит
название следующего за ним месяца(с помощью оператора case) Например: если я ввожу 2 должно выйти мартОтветы на вопрос
var
Month: 1..12; //Номер месяца(число от 1 до 12)
begin
writeln('Введите номер месяца');
readln(Month);
case Month of
1: writeln('Февраль');
2: writeln('Март');
3: writeln('Апрель');
4: writeln('Май');
5: writeln('Июнь');
6: writeln('Июль');
7: writeln('Август');
8: writeln('Сентябрь');
9: writeln('Октябрь');
10: writeln('Ноябрь');
11: writeln('Декабрь');
12: writeln('Январь');
end;
end.
Конечно, вот пример программы на языке Pascal, которая выполняет указанную задачу:
```pascal program NextMonth;
var monthNumber: integer;
begin // Ввод номера месяца writeln('Введите номер месяца (от 1 до 12): '); readln(monthNumber);
// Проверка корректности введенного номера месяца if (monthNumber < 1) or (monthNumber > 12) then writeln('Некорректный номер месяца.') else begin // Вывод названия следующего месяца с использованием оператора case case monthNumber of 1: writeln('Январь -> Февраль'); 2: writeln('Февраль -> Март'); 3: writeln('Март -> Апрель'); 4: writeln('Апрель -> Май'); 5: writeln('Май -> Июнь'); 6: writeln('Июнь -> Июль'); 7: writeln('Июль -> Август'); 8: writeln('Август -> Сентябрь'); 9: writeln('Сентябрь -> Октябрь'); 10: writeln('Октябрь -> Ноябрь'); 11: writeln('Ноябрь -> Декабрь'); 12: writeln('Декабрь -> Январь'); end; end;
readln; // Чтобы окно консоли не закрылось сразу после выполнения программы end. ```
Программа сначала запрашивает у пользователя ввод номера месяца. Затем она проверяет корректность введенного номера и, если он корректен, использует оператор case для определения названия следующего месяца и выводит соответствующее сообщение. Если введенный номер месяца некорректен, программа выводит сообщение об ошибке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
