ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить из слова X те буквы,
которые встречаются в слове Z. Слова X и Z введите с клавиатуры.Ответы на вопрос
i: integer;
begin
x:= 'клавиатура';
z:= 'буква';
for i:=1 to length(z) do
while pos(z[i],x)>0 do delete (x,pos(z[i],x),1);
writeln(x);
end.
Результат:
литр
Программа на языке Паскаль может выглядеть следующим образом:
```pascal program DeleteLetters; var X, Z, Result: string; i: integer; begin // Ввод слов X и Z с клавиатуры writeln('Введите слово X:'); readln(X); writeln('Введите слово Z:'); readln(Z); // Инициализация результирующей строки Result := ''; // Перебор всех символов в слове X for i := 1 to length(X) do begin // Проверка, содержится ли текущий символ в слове Z if pos(X[i], Z) = 0 then begin // Если символ не содержится, добавляем его в результирующую строку Result := Result + X[i]; end; end; // Вывод результата writeln('Результат:', Result); end. ```
Программа сначала запрашивает у пользователя ввод слова X, затем вводит слово Z. Затем она проходит по каждому символу в слове X и проверяет, содержится ли этот символ в слове Z. Если символ не содержится, он добавляется в результирующую строку Result. В конце программа выводит полученный результат.
Например, если ввести X = 'Привет' и Z = 'Пока', программа удалит из слова X буквы 'к' и 'а' и выведет результат 'Привет'.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
